Updates
Incident Report for EyeSpace
Resolved
This incident has been resolved.
Posted Sep 03, 2019 - 21:45 AEST
Update
We are continuing to monitor for any further issues.
Posted Sep 03, 2019 - 17:01 AEST
Update
Distributor notifications now appear in Slack. Please email jake@eyespacelenses.com for an invitation if you do not have access already.

Order update functionality is temporarily unavailable due to upgrades. This will be back up soon.
Posted Sep 03, 2019 - 17:01 AEST
Monitoring
We are in the process of deploying updates. No more than a few minutes of downtime is expected.
Posted Sep 03, 2019 - 15:31 AEST
This incident affected: EyeSpace Desktop.