User interface updates
Incident Report for EyeSpace
Resolved
This incident has been resolved.
Posted Dec 16, 2019 - 20:40 AEDT
Investigating
We are running some updates which will interrupt access to online simulations, knowledge base, and troubleshoot forms. Orders and order processing is uninterrupted.
Posted Dec 16, 2019 - 00:57 AEDT
This incident affected: EyeSpace Online.