Ordering System
Incident Report for EyeSpace
Resolved
The issue has been resolved. We require all users to update either via the auto-updater or direct download here: https://storage.googleapis.com/eyespace-desktop-releases/EyeSpace_3_7_17.exe
Posted Apr 08, 2020 - 19:53 AEST
Update
Bugfix update is complete and available here: https://storage.googleapis.com/eyespace-desktop-releases/EyeSpace_3_7_17.exe
This will also be delivered via the auto-updater today.
Posted Apr 08, 2020 - 15:07 AEST
Monitoring
We have finished the bug-fix update and are now testing prior to release.
Posted Apr 08, 2020 - 12:13 AEST
Update
We have been working tirelessly on this issue and have identified a fix.

Unfortunately the fix requires a patch to EyeSpace, which must be thoroughly tested before release. We will continue working on this, and the patch will be delivered via the auto-updater by 2pm tomorrow Adelaide time.

In the meantime:

- EyeSpace Online is fully operational.
- EyeSpace desktop can be used to design lenses, but will show an error message when placing an order.
Posted Apr 07, 2020 - 22:55 AEST
Update
We are continuing to work on a fix for this issue. This requires restarting our servers, so EyeSpace Online will see intermittent outages.
Posted Apr 07, 2020 - 17:58 AEST
Identified
We have received reports that EyeSpace Desktop produces an error message when placing orders. The issue appears to be widespread.

The issue appears to be security related. Some clients are unable to create a secure SSL connection to our server.

We are currently investigating a fix.
Posted Apr 07, 2020 - 14:44 AEST
This incident affected: EyeSpace Online and EyeSpace Desktop.